Krauler1
03.03.2020 04:29

Решить в паскале: составить программу,проверяющую,является ли заданное натуральное число палиндромом,т.е. таким,которое читается одинаково слева направо и справа налево(например: 23132).

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
катя134689
10.06.2020 23:24

var n, m, p: word;
begin
write('Enter number: ');
readln(n);
m := n;
p := 0;
while m > 0 do begin
p := p * 10 + m mod 10;
m := m div 10;
end;
if n = p then
writeln('Palindrome')
else
writeln('Not palindrome');
readln;
end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота