masha71301291
19.05.2022 21:15

Написать программу в пачкали, чтобы решить это ​


Написать программу в пачкали, чтобы решить это ​

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
ibraevaira
26.07.2022 12:28
Var i,j,s,k:integer;
begin
s:=0; k:=0;
for i:=1 to 9 do
 for j:=0 to 9 do
  begin
  s:=s+i*100+j*10+i;
  k:=k+1;
  end;
writeln('s = ',s,' k = ',k,' sred = ',s/k:6:2);
end.

Результат:
s = 49500 k = 90 sred = 550.00

Если нужно приложение с формой, то:
помещаете на форме командную кнопку (Button) и статичный текст (StaticText).
В обработчик кнопки добавляете код:
procedure TForm1.Button1Click(Sender: TObject);
var i,j,s,k:integer; s:string;
begin
 s:=0; k:=0;
 for i:=1 to 9 do
  for j:=0 to 9 do
   begin
   s:=s+i*100+j*10+i;
   k:=k+1;
   end;
   s:='s = '+IntToStr(s)+' k = '+IntToStr(k)+' sred = '+FloatToStr(s/k);
  StaticText1.Caption := s;
end;
0,0(0 оценок)
Ответ:
rmshturkop01n73
26.07.2022 12:28
Var i,j,s,k:integer;
begin
s:=0; k:=0;
for i:=1 to 9 do
 for j:=0 to 9 do
  begin
  s:=s+i*100+j*10+i;
  k:=k+1;
  end;
writeln('s = ',s,' k = ',k,' sred = ',s/k:6:2);
end.

Результат:
s = 49500 k = 90 sred = 550.00

Если нужно приложение с формой, то:
помещаете на форме командную кнопку (Button) и статичный текст (StaticText).
В обработчик кнопки добавляете код:
procedure TForm1.Button1Click(Sender: TObject);
var i,j,s,k:integer; s:string;
begin
 s:=0; k:=0;
 for i:=1 to 9 do
  for j:=0 to 9 do
   begin
   s:=s+i*100+j*10+i;
   k:=k+1;
   end;
   s:='s = '+IntToStr(s)+' k = '+IntToStr(k)+' sred = '+FloatToStr(s/k);
  StaticText1.Caption := s;
end;
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота