Лилиана2001256
22.12.2022 04:18

Напишите программу перевода чисел из двоичной системы счисления в десятичную на паскале , используя простые формулы.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Мика7771
03.10.2020 02:27
Var a:string[20]; st,b,i:integer;
begin
writeln('Введите двоичное число:');
readln(a);
st:=1; b:=0;
for i:=length(a) downto 1 do
 begin
 if a[i]='1' then b:=b+st;
 st:=2*st;
 end;
writeln(b);
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота