givlinkovpaschozszti
10.09.2022 02:04

Написать программу на питон! У Даши есть два брата — Даня и Дима. А еще у нее есть n конфет, вкус i-й конфеты можно оценить как ai (чем больше число, тем конфета вкуснее, причем некоторые конфеты настолько невкусные, что это число отрицательное). Недавно Даша поссорилась с Димой, поэтому теперь она хочет раздать своим братьям конфеты так, чтобы разница между суммарной вкусностью Даниных и Диминых конфет была максимальна. При этом вовсе не обязательно, чтобы Даня с Димой получили одинаковое число конфет, кто-то из них может даже не получить ни одной конфеты Даше разделить конфеты таким образом, чтобы Дима чувствовал себя максимально обиженным. Входные данные В первой строке ввода задано число n — количество конфет (1⩽n⩽106). В следующей строке через пробел перечислены числа ai — параметры вкусности конфет (−103⩽ai⩽103). Выходные данные Выведите единственное число — максимальную возможную разность между суммарной вкусностью конфет Дани и конфет Димы, которую можно достичь.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
kirasanovnagmailcom
15.10.2020 19:51

n = int(input())

him = 0

her = 0

a = list(map(int, input().split()))

for elem in a:

 if elem < 0:

   him += elem

 else:

   her += elem

print(her - him)

# логика такая создаём him и her для качества конфет для

# обиженного петуха и красотки соответственно

# к him прибавляем только отрицательные значения

# а к her -  положительные и выводим разницу

   

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота