ANgeLOL1112
13.01.2020 16:50

Решить на языке питон 3. В шкатулке хранится разноцветный бисер (или бусины). Все бусины имеют одинаковую форму, размер и вес. Бусины могут быть одного из N различных цветов. В шкатулке много бусин каждого цвета. Требуется определить минимальное число бусин, которые можно не глядя вытащить из шкатулки так, чтобы среди них гарантированно были две бусины одного цвета. Формат ввода Содержит одно натуральное число N - количество цветов бусин ( 1 ≤ N ≤ 10 в 9 степени ) . Формат вывода Выведите ответ на поставленную задачу.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
сархан2007
10.06.2020 07:59

Объяснение:

если индексы в нумерации от 0:

#include<iostream>

int main()

{

int i,j,m,n,K;

double S,a;

K=0;

S=0;

std::cin>>m>>n>>K;

for(int i=0; i<m; i++)

{

for(int j=0; j<n; j++)

{

std::cin>>a;

if(i+j==K) S+=a;

}

}

std::cout<<S;

return 0;

}

если индексы в нумерации от 1:

#include<iostream>

int main()

{

int i,j,m,n,K;

double S,a;

K=0;

S=0;

std::cin>>m>>n>>K;

for(int i=1; i<=m; i++)

{

for(int j=1; j<=n; j++)

{

std::cin>>a;

if(i+j==K) S+=a;

}

}

std::cout<<S;

return 0;

}

0,0(0 оценок)
Ответ:
darina224
01.06.2021 15:14
// PascalABC.NET 3.0, сборка 1144 от 16.01.2016
type
  Point=record
  x,y:real
  end;

function GetPoint(c:char):Point;
begin
  Writeln('Введите координаты точки ',c,':');
  Read(Result.x,Result.y)
end;

function Line(A,B:Point):real;
begin
  Result:=sqrt(sqr(B.x-A.x)+sqr(B.y-A.y))
end;

function SqTriangle(pA,pB,pC:Point):real;
begin
  var a:=Line(pB,pC);
  var b:=Line(pA,pC);
  var c:=Line(pA,pB);
  if (a+b>c) and (a+c>b) and (b+c>a) then begin
    var p:=(a+b+c)/2;
    Result:=sqrt(p*(p-a)*(p-b)*(p-c))
    end
  else Result:=0
end;

begin
  var A:=GetPoint('A');
  var B:=GetPoint('B');
  var C:=GetPoint('C');
  Writeln('Площадь треугольника равна ',SqTriangle(A,B,C))
end.

Тестовое решение:
Введите координаты точки A:
-5 3.18
Введите координаты точки B:
1.45 6.2
Введите координаты точки C:
6 -5.93
Площадь треугольника равна 45.98975
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота