Daney213
07.08.2021 13:56

Составьте программу, которая генерирует случайное четы- рехзначное число от 1000 до 9999 (номер автобусного билета), выводит
его на экран и определяет, является ли билет «счастливым» (сумма
первых двух цифр равна

сумме последних двух цифр).​

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
амаеру
07.09.2020 23:01

Var i,C,B:integer;A:Array[1..5]of integer;

Begin

 C:=1;B:=9;

 for i:=1 to 4 do

   A[i]:=random(b-c+1)+c;      

   Write('Билет-');

   For i:=1 to 4 do

    Write(A[i]);

   If A[1]+A[2]=A[3]+A[4] then Begin Writeln; writeln('Билет счастливый')end else Begin Writeln; writeln('Билет не счастливый');end;

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота