vaaaadimg
29.11.2021 11:33

Решите на Python Сумма квадратов По данному натуральному n вычислите сумму 12+22+32+...+n2. Входные данные Вводится натуральное число, не превосходящее 100. Выходные данные Выведите ответ на задачу. Примеры Ввод Вывод 3 14

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
alek09
15.10.2020 15:57

Алгоритм: есть несколько решить эту задачу, смотря что от Вас требуется. Можно реализовать цикл, который каждый раз прибавляет к сумме квадрат следующего числа (сложность O(n)), а можно воспользоваться формулой 1^2+2^2+\ldots+n^2=\dfrac{n(n+1)(2n+1)}{6} и сразу выдать верный ответ (сложность O(1)).

Решение с цикла:

s = 0

for i in range(1, int(input())+1):

   s += i*i

print(s)

Решение с формулы:

n = int(input())

print(n*(n+1)*(2*n+1) // 6)

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота