annapar2017p00w0y
28.05.2021 08:00

Задание на С# Задание: Дан массив, состоящий из целых чисел. Нумерация элементов начинается с 0. Напишите программу, которая выведет элементы массива, номера которых четны (0, 2, 4...). Входные данные Сначала задано число N — количество элементов в массиве (1<=N<=100). Далее через пробел записаны N чисел — элементы массива. Массив состоит из целых чисел. Выходные данные Необходимо вывести все элементы массива с чётными номерами. Решение:
using System;
using System.IO;
namespace ConsoleApp2
{ class Program
{ static void Main(string[] args)
{ int a = Int32.Parse(Console.ReadLine());
string text = Console.ReadLine();
string[] arraystring = text.Split(new char[] { ' ' });
int[] arrayy = new int[a];
int b = 0;
for (int i = 0; i < a; i++) { b = Int32.Parse(arraystring[i]);
arrayy[i] = b;
if (i % 2 == 0) ;
{ Console.Write(arrayy[i] + " "); } } } } }

Оно почему то не работает, найдите ошибку

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
yarroslawfd
15.10.2020 15:21
C#

Задача не предполагает создание нового массива, в ней сказано "вывести все элементы массива с чётными номерами".

int a = Int32.Parse(Console.ReadLine()); string text = Console.ReadLine(); string[] array = text.Split(' '); for (int i = 0; i < a; i+=2) Console.Write(array[i] + " "); Console.WriteLine(); Console.ReadLine();

или можно используя System.Linq ("int a" даже лишняя):

int a = Int32.Parse(Console.ReadLine()); string text = Console.ReadLine(); string[] array = text.Split(' '); Console.WriteLine(string.Join(' ', array.Where((x,i) => i%2==0))); Console.ReadLine();

Пример работы:


Задание на С# Задание: Дан массив, состоящий из целых чисел. Нумерация элементов начинается с 0. Нап
Задание на С# Задание: Дан массив, состоящий из целых чисел. Нумерация элементов начинается с 0. Нап
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота