kotkat2014
23.12.2022 21:51

Дана блок-схема алгоритма обработки целочисленного массива A из 10 элементов. Чему будет равна переменная cnt после завершения работы алгоритма, если изначально: A = {1, 2, 8, 2, 3, 6, 2, 4, 2, 2}. Индексация элементов массива начинается с 1. В ответе укажите число.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
safeon
30.10.2022 11:55
Пошаговая детализацияпредставляет собой простой процесс, предпола­гаю­щий первоначальное выражение логики модуля в терминах гипотети­чес­кого (условного) языка высокого уровня с последующей детализацией каждого предложения в терминах языка более низкого уровня, до тех пор, пока, наконец, не будет достигнут уровень используемого языка программи­рования. здесь уместно напомнить: чем меньше язык содержит деталей, тем более он высокого уровня. можно считать языком самого высокого уровня обычную человеческую речь, а языком низкого уровня — машинный язык.
0,0(0 оценок)
Ответ:
iskanderkhusano
17.03.2022 13:40
1. Треугольник будет существовать если будут выполнятся одновременно три неравенства:
x + y > z
x + z > y
y + z > x

Программа:

var x, y, z: real;
begin
  writeln('Введите стороны треугольника x, y, z: ');
  read(x, y, z);
  if (x + y > z) and (x + z > y) and (y + z > x) 
  then writeln('Треугольник существует')
  else writeln('Треугольник не существует');
end.

2. Думаю, здесь излишни объяснения.

Программа:

var x, y, z: real;
begin
  writeln('Введите три числа: ');
  read(x, y, z);
  writeln('В интервале (1; 3) лежат числа: ');
  if (x > 1) and (x < 3) then writeln(x);
  if (y > 1) and (y < 3) then writeln(y);
  if (z > 1) and (z < 3) then writeln(z);
end.

Блок-схемы в приложении:
Составить блок-схему и написать программу на языке pascalabc.net. 1. даны действительные положительн
Составить блок-схему и написать программу на языке pascalabc.net. 1. даны действительные положительн
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота