valikkk1
10.05.2020 05:55

Составить программу вычисления значения выражения: c = a^2 + 10sin ( 2b−4 )

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
mashacat5571
06.02.2020 23:17

1.В содержательном подходе количество информации, заключённое в сообщении, определяется объёмом знаний, который это сообщение несёт получающему его человеку. Один бит - это минимальная единица измерения количества информации. Сообщение, уменьшающее неопределённость знания в два раза, несёт один бит информации.

2.Вероятностный подход предполагает, что возможные события имеют различные вероятности реализации. ... Качественная связь между вероятностью события и количеством информации в сообщении состоит в следующем: чем меньше вероятность некоторого события, тем больше информации содержит сообщение об этом событии.

3.Эта единица называется бит. Сообщение, уменьшающее неопределенность знаний в два раза, несет 1 бит информации. Неопределенность знаний о некотором событии – это количество возможных результатов события.

4.Формула Хартли или хартлиевское количество информации или мера Хартли - логарифмическая мера информации, которая определяет количество информации, содержащееся в сообщении. ... Формула была предложена Ральфом Хартли в 1928 году как один из научных подходов к оценке сообщений.

5.Случа́йное собы́тие — подмножество множества исходов случайного эксперимента; при многократном повторении случайного эксперимента частота наступления события служит оценкой его вероятности.

0,0(0 оценок)
Ответ:
Z1439373
19.05.2023 07:05
Class ArrayMultiplication{
 public static void main(String args[]){
  String fileName = "Array.txt", aNum = ""; int nArray[] = new int[201], iChar; nArray[0] = 0; long rMulti;
  java.io.FileReader iFile = null; java.io.FileWriter oFile = null;
  try{
   iFile = new java.io.FileReader(fileName);
   while((iChar = iFile.read())!=-1)
    if(iChar!=' ')aNum+=(char)iChar;
    else {nArray[++nArray[0]] = new Integer(aNum);aNum="";}
   if(!aNum.equals(""))nArray[++nArray[0]] = new Integer(aNum);
   oFile = new java.io.FileWriter(fileName);
   for(rMulti = 1; nArray[0]>0; nArray[0]--)rMulti*=nArray[nArray[0]];
   oFile.write(rMulti+"");
  }catch(java.io.FileNotFoundException fnfe){
   System.out.println("Файл не был найден!");
  }catch(java.io.IOException ioe){
   System.out.println("Ошибка ввода/вывода в файл!");
  }finally{
   try{
 iFile.close(); oFile.close();
   }catch(java.io.IOException ioe){
 System.out.println("Ошибка закрытия файла ввода/вывода!");
   }
  }
 }
}
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота