belayazima
25.10.2021 00:21

Здравствуйте ? Напишите программу, которая выводит на экран список товаров и их цен в виде чека. Товары и их цены хранятся в программе в двух списках одинаковой длины:

items = ['Milk', 'Bread', 'Cheese', 'Chocolate', 'Water']

prices = [10, 5, 20.5, 7.15, 2.99]

Пример вывода:

Name Price

Milk 10.00

Bread 5.00

Cheese 20.50

Chocolate 7.15

Water 2.99

Указания:

Длина названия товара - не больше 20 символов

Длина цены - не больше 6 символов

Цены должны быть округлены до 2 знаков после запятой с форматирования. Используйте любой форматирования для этого (%, format, f-строку).

Выравнивание строк в виде таблицы можно сделать любым , даже написать цикл, который добавляет к строке пробелы до заданной длины с нужной стороны.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Guppy2016
04.05.2022 13:31

1-b

2-a

3-a

4-c

5-a

Объяснение:

1. Какие задачи выполняют уровни OSI в процессе передачи данных по сети:

a) уровни выполняют одинаковые задачи, постоянно повторяя передающие сигналы по сети;

b) каждый уровень выполняет свою определенную задачу;

c) первых три уровня выполняют одинаковые задачи, последующие выполняют определенные задачи.

2. Верно ли утверждение: «Каждый уровень модели выполняет свою функции. Чем выше уровень, тем более сложную задачу он решает»:

a) верно;

b) не верно.

3. Какой уровень управляет передачей данных по сети и обеспечивает подтверждение передачи:

a) транспортный;

b) канальный;

c) сеансовый.

4. Какой уровень поддерживает взаимодействие между удаленными процессами:

А) транспортный;

b) канальный;

c) сеансовый.

5. Какой уровень управляет потоками данных, преобразует логические сетевые адреса и имена в соответствующие им физические:

a) сетевой;

b) представительский;

c) транспортный.

Вроде так)

0,0(0 оценок)
Ответ:
лиод1
06.06.2021 00:11

Відповідь:

Пояснення:

//Реализация задачи №1 "A+B" на C

#include < stdio.h >

long a,b;

int main(){

freopen("input.txt","r",stdin);

freopen("output.txt","w",stdout);

scanf("%ld%ld",&a,&b);

printf("%ld",a+b);

return 0;

}  

7

{Реализация задачи №1 "A+B" на Pascal}

var a, b : longint;

begin

assign(input, 'input.txt'); reset(input);

assign(output, 'output.txt'); rewrite(output);

read(a, b);

write(a + b);

end.

//Реализация задачи №1 "A+B" на Java

import java.util.*;

import java.io.*;

public class Main{ //имя класса должно быть Main

public static void main(String[] argv) throws IOException{

new Main().run();

}

PrintWriter pw;

Scanner sc;

public void run() throws IOException{

sc = new Scanner(new File("input.txt"));

int a=sc.nextInt(), b=sc.nextInt();

pw = new PrintWriter(new File("output.txt"));

pw.print(a+b);

pw.close();

}

}

'Реализация задачи №1 "А+В" на Basic

open "input.txt" for input as #1

open "output.txt" for output as #2

input #1,a#,b#

print #2,a#+b#

close #1

close #2

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота