sonyacherepanova
13.10.2020 00:57

программа Python Составить программу для вычисления количества всех чётных двухзначных двузначных положительных чисел.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Polybel
15.10.2020 14:26

В массив добавляются случайные числа в диапазоне от -150 до 150. Дальше код обрабатывает массив в соответствии с вашими требованиями (а именно: "вычисление количества всех чётных двузначных положительных чисел"). Прикрепил также скриншот с кодом и выводом компилятора:

import random

numbers = []

am = int(input("amount of numbers = "))

for i in range (am):

   numbers.append(random.randint(-150,150))

print(*numbers)

count = 0

for i in range (am):

   if ((numbers[i] % 2 == 0) and (numbers[i] > 0)):

       if (len(str(numbers[i])) == 2):

           count += 1

print ("amount of all even two-digit positive numbers = ", count)


программа Python Составить программу для вычисления количества всех чётных двухзначных двузначных по
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота