Vlad584q
12.02.2023 08:59

Составьте программу, которая для целого числа k (от 1 до 99), введенного вами, напечатает фразу «Мне k лет», при этом в нужных случаях слово «лет» заменяя на слово «год» или «года».

На языке Паскаль
С использованием оператора switch, case

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Сергій098765
06.08.2020 15:53

var

Age : integer;

begin

Repeat

Write('Введите Ваш возраст: ');

Readln(Age);

until Age in [1..99];

if Age in [10..20] then Writeln('Мне ', Age, ' лет') else

case Age mod 10 of

1: Writeln('Мне ', Age, ' год');

2, 3, 4 : Writeln('Мне ', Age, ' года');

0, 5..9 : Writeln('Мне ', Age, ' лет');

end;

end.

0,0(0 оценок)
Ответ:
elenalm
06.08.2020 15:53

// PascalABC.NET

begin

 var n := ReadInteger('Введите возраст (1-99):');

 if not (n in 1..99) then

   Print('Неверный возраст')

 else if n in 10..20 then

   Print('Мне', n, 'лет')

 else

   case n mod 10 of

     1: Print('Мне', n, 'год');

     2..4: Print('Мне', n, 'года');

   else Print('Мне', n, 'лет')

   end;

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота