Мишутка890
07.09.2022 00:44

) , позволяющую:

1. Ввести элементы представленных в Приложении A массивов в компьютер для последующей их обработки.

2. Вывести элементы массивов на экран для проверки правильности их ввода.

3. Третье задание взять по номеру варианта из Приложения B.

приложение А

Значения элементов первого массива 5 4 -5 6 7 8 1

Значения элементов второго массива 5 3 1 -7 -6 1 2

приложение В

Расположить элементы первого массива по убыванию их значений, элементы второго массива по возрастанию, а затем создать третий массив, элементы которого будут равны сумме соответствующих элементов первых двух массивов.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
yanachor25
11.04.2022 06:56
1. Вот так это пишется с функцией

// PascalABC.NET 3.1, сборка 1200 от 13.03.2016
function IsPrime(n:integer):boolean;
begin
  if n<4 then Result:=True
  else begin
    var found:= (n mod 2 = 0);
    var p:=3;
    while (not found) and (sqr(p)<=n) do
      begin
      found:=(n mod p = 0);
      p+=2
      end;
    Result:=not found
    end
end;

begin
  Writeln('k=',ArrRandom(ReadInteger('n='),1,999).Println.
    Where(x->IsPrime(x)).Count)
end.

Тестовое решение:
n= 10
401 828 780 444 694 965 23 341 673 875
k=3

2. А вот так это пишется с процедурой

// PascalABC.NET 3.1, сборка 1200 от 13.03.2016
procedure IsPrime(n:integer; var res:boolean);
begin
  if n<4 then res:=True
  else begin
    var found:= (n mod 2 = 0);
    var p:=3;
    while (not found) and (sqr(p)<=n) do
      begin
      found:=(n mod p = 0);
      p+=2
      end;
    res:=not found
    end
end;

begin
  var a:=ArrRandom(ReadInteger('n='),1,999); a.Println;
  var k:=0;
  var prime:boolean;
  foreach var e in a do begin
    IsPrime(e,prime);
    if Prime then Inc(k)
    end;
  Writeln('k=',k)
end.

Тестовое решение:
n= 12
199 43 71 365 417 904 170 212 694 103 161 689
k=4
0,0(0 оценок)
Ответ:
vabimGogolev
25.02.2020 09:52
Для выбора водящего в детской игре N человек становятся в круг, после чего произносится считалка. На первом слове считалки указывается на первого человека в кругу, на втором слове – на второго человека и т. д. После N-го человека снова идёт первый человек (все люди в кругу пронумерованы числами от 1 до N, круг зацикливается, после человека с номером N идёт человек с номером 1). Всего в считалке M слов. Определите, на какого человека придётся последнее слово считалки. Программа получает на вход два целых положительных числа. Первое число N – количество людей в кругу. Второе число M – количество слов в считалке. Оба числа не превосходят 109 . Программа должна вывести одно целое число от 1 до N – номер человека в кругу на которого придётся последнее слово считалки.

var N,k,f,M: longint;beginwriteln ('ВВЕДИТЕ КОЛ-ВО ЛЮДЕЙ В ИГРЕ: ');read(N);writeln('ВВЕДИТЕ КОЛ-ВО СЛОВ: ');read(M);K:=M div N ;F:=M-K*N;if f=0 then write ('НОМЕР ЧЕЛОВЕКА, НА КОТОРОГО ПРИДЕТСЯ ПОСЛЕДНЕЕ СЛОВО  >>  ',N) elsewrite('НОМЕР ЧЕЛОВЕКА, НА КОТОРОГО ПРИДЕТСЯ ПОСЛЕДНЕЕ СЛОВО  >>  ',F);end.                                                                   
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота