Milalenka1
01.05.2023 21:00

Напишите программу в ПИТОНЕ, которая в последовательности натуральных чисел определяет количество чисел, оканчивающихся на 6. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последова-тельности всегда имеется число, оканчивающееся на 6. Количество чисел не превышает 1000. Введённые числа не превышают 30 000. Программа должна вывести одно число – количество чисел, оканчивающихся на 6.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
vyyy73ozxnyb
15.10.2020 12:40

print(len([i for i in [int(input()) for i in range(int(input()))] if i % 10 == 6]))

0,0(0 оценок)
Ответ:
dfoddo
15.10.2020 12:40

def ReadSeq(SeqLen: int, CastType):

   for _ in range(SeqLen):

       yield CastType(input())

def main():

   Sequence = ReadSeq(int(input()), int)

   filtered = filter(lambda p: str(p).endswith('6'), Sequence)

   print(len(list(filtered)))

if __name__ == '__main__':

   main()

Да, моя версия конечно занимает побольше строк, чем другое предложенное решение, но эффективнее расходует память, и, как по мне, немного легче воспринимается на глаз.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота