lyubaykind
07.03.2022 05:21

ПИТОН!
На дискотеке в ряд стоят три прожектора, которые поочерёдно светят в следующем порядке: левый, средний, правый, средний, левый, средний, правый, средний и т.д. (слева направо, затем налево, опять направо, ...). Каждый прожектор горит в течение одной секунды.

Известно, что лампа левого прожектора имеет ресурс A секунд горения, среднего – B секунд, правого – С секунд. Определите, сколько времени сможет продолжаться этот процесс горения прожекторов.

Входные данные
Программа получает на вход три целых неотрицательных числа A, B, C – время горения левого, среднего, правого прожектора.

Выходные данные
Программа должна вывести одно целое число.

Система оценивания
Решение, правильно работающее только для случаев, когда все входные числа не превосходят 10, будет оцениваться в

Решение, правильно работающее только для случаев, когда все входные числа не превосходят 104, будет оцениваться в

В будет оцениваться решение, правильно работающее, когда сумма всех входных чисел по модулю не превосходит 2×10^9
Пример:
Ввод: 3 3 3
Вывод: 7
Пояснение: прожектора горят в следующем порядке: левый, средний, правый, средний, левый, средний, правый. После этого должен загореться средний прожектор, но он уже выработал ресурс и загореться не сможет. Поэтому процесс обрывается после 7 с.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Музалевская
08.11.2022 22:39
Значит так: мы создаем массив избыточной длины, куда потом будем записывать рандомные числа. Так же мы создаем массив-счетчик b (у него индексами являются сами числа, а элементами - количество этого числа в массиве А), куда будет присваиваться, сколько раз нам встречается то или иное число (перед этим мы массив обязательно обнулим). В конце мы смотрим максимальное число из массива-счетчика. Вуаля!

Вот пример программы на паскале ABC:

var a:array [1..1000000] of integer; 
b:array [1..10] of longint;   
c:integer;   
i,max,n:longint;
begin
write('Введите число элементов массива: ');
readln(n); 
max:=0; 
for i:=1 to 10 do 
b[i]:=0; 
for i:=1 to n do  begin 
a[i]:=random(10)+1; 
write(a[i],' '); 
b[a[i]]:=b[a[i]]+1 
end; 
for i:=1 to 10 do if b[i]>max then 
begin 
c:=i; 
max:=b[i] 
end; 
writeln; 
writeln('Чаще всего в массиве встречается число ',c)
end.
0,0(0 оценок)
Ответ:
сичоврчс
05.08.2020 15:09
Апр,  школа №151 мурманской области вам: 1) 24 буквы + 8 цифр = 32 символа 2) 32 символа + 1 пробел = 33 символа 3) а так как для 32 символов нужно 5 бит, то для 33 символов нужно 6 бит ответ: i = 6 бит 2. здесь каждый раз придется задавать вопросы, чтобы  уменьшить количество возможных вариантов. 1) больше или меньше 32? 2) больше или меньше 16? 3) больше или меньше 8? 4) больше или меньше 4? 5) больше или меньше 2? ответ: 5 вопросов. 3. не смогу . мне задали другое . удачи. 3 уже обеспечена : )
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота