earthas
03.10.2022 18:01

2. Написать программу, которая будет складывать, вычитать, умножать или делить два числа. Числа и знак операции вводятся пользователем. После выполнения вычисления программа не должна завершаться, а должна запрашивать новые данные для вычислений. Завершение программы должно выполняться при вводе символа '0' в качестве знака операции. Если пользователь вводит неверный знак (не '0', '+', '-', '*', '/'), то программа должна сообщать ему об ошибке и снова запрашивать знак операции. Также сообщать пользователю о невозможности деления на ноль, если он ввел 0 в качестве делителя.
На с++

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
kashavcevaeliz
16.12.2021 04:23

1. провести скан компьютера антивирусом

2. если нашёл антивирус то очистить

3. если не нашёл ищем вирус вручную

4. если реклама в браузере то ищем через код элемента

5. если нашли то следуем к корневой папке и удаляем

6. если рекламка на самом пк, то стоит нажать, и скачав утилиту просмотреть последние действия и с каким файлом они совершались, в последствии удалить

7. если же вирус типа троян, то так же с какой-либо утилиты просмотреть какие файлы недавно появились на пк и удалить

8. если же они не удаляются, являясь задействованными где либо, с диспетчера задач завершаем задачу и удаляем

9. в случае если файл скрыт, через проводник включаем видимость скрытых файлов и папок и удаляем

10. в случае если данный файл не удаляется вообще, можно просто его отключить, либо через сторонние программы, дающие право удалять корневые программы избавиться от них

11. ещё раз на всякий случай включить полную проверку антивирусом

0,0(0 оценок)
Ответ:
DanchikSummer
22.10.2021 18:27

/// PascalABC.Net 3.4.2, 2053(11.05.19)

var

   a, n: longint;

   text: textfile;

function myMod(num, power, divider: longint): longint;

var

   rest, i: longint;

begin

   rest:=1;

   divider := abs(divider);

   for i := 1 to power do

   begin

       rest := rest * num;

       rest := rest mod divider;

   end;

   

   myMod := rest;

end;

begin

   assign(text, 'input.txt');

   

   {rewrite(text);

   writeln(text, 109);

   close(text);}

   

   reset(text);

   read(text, a);

   writeln('a=', a);

   close(text);

   

   n := 1;

   repeat

       n := n + 1;

   until MyMod(n, n, a) = 0;

   

   assign(text, 'output.txt');

   rewrite(text);

   writeln(text, n);

   close(text);

   

   {reset(text);

   read(text, n);

   writeln('n=', n);

   close(text);}

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота