VeronikaBruhova
24.09.2021 01:56

Напишите программу, которая определяет максимальное значение среди введенных чисел до нуля

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
ksysharaz
16.09.2020 01:52
Как я понял, 0 - условие окончания ввода последовательности. Тогда может получиться так:
//PascalABC.NET (версия 3.1, сборка 1210 от 29.03.2016)
var a,max:integer;
begin
  max:=-MaxInt;
  repeat
    readln(a);
    if a>max then max:=a;
  until a=0;
  writeln('max = ',max);
end.

Тестовое решение:
25
11
43
34
23
65
12
36
0
max = 65
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота