муха68
24.03.2021 15:15

сделать задания на python
Напишите программу, которая запрашивала бы у пользователя:

4. Дана строка. Вывести все слова, начинающиеся на букву "а" и слова оканчивающиеся на букву "я".

5. 1. Найти максимальный элемент численного массива и поменять его местами с минимальным.

5.2. Программа заполняет одномерный массив из 10 целых чисел числами, считанными с клавиатуры. Определить среднее арифметическое всех чисел массива. Заменить элементы массива большие среднего арифметического на 1.

6. 1. Составить программу для нахождения чисел из интервала [М, N], имеющих наибольшее количество делителей.

6.2.Четыре точки заданы своими координатами X(x1, x2), Y(y1, y2), Z(z1, z2), P(p1, p2). Выяснить, какие из них находятся на максимальном расстоянии друг от друга и вывести на экран значение этого расстояния. Вычисление расстояния между двумя точками оформить в виде процедуры

7. 1. Задана квадратная матрица. Переставить строку с максимальным элементом на главной диагонали со строкой с заданным номером m.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
ATimofeeva
17.12.2022 17:08
C#. Код ниже.

using System;
namespace ConsoleApp1{    class Program    {        static void Main(string[] args)        {            //переменная для хранения суммы, изначально = 0            var sum = 0;            //вводимое число, изначально = 0            int number = -1;            //пока число не равно 0            while (number != 0)            {                //выводим сообщение с ввести число                Console.Write("Введите число: ");                //вводим число                number = int.Parse(Console.ReadLine());                //суммуируем                sum += number;            }            //Выводим результат            Console.WriteLine("Выход из цикла. Сумма = " + sum);            Console.ReadKey();        }    }}
0,0(0 оценок)
Ответ:
Алисмит
25.09.2022 10:53
В операторах Dat[1] := 7; ... ; Dat[10] := 9; задаются элементы массива.
m := 0; n := 0; - начальные значения переменных m и n.
В цикле for k := 1 to 10 do ... каждый элемент массива сравнивается с текущим значением переменной m (Dat[k] >= m). Если элемент больше, то значения переменных m и n меняются: в переменной m запоминается значение элемента массива, в переменной n - значение номера (индекс) этого элемента. Таким образом, после выполнения цикла значения переменных будут: m=10; n=8. На экран будет выведено значение 8 (это номер последнего максимального элемента массива).
ответ: 8
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота