Ksuha1304
23.01.2020 05:13

Написать программу на Питоне
Ход слона
Шахматный слон ходит по диагонали. Даны две различные клетки шахматной доски, определите, может ли слон попасть с первой клетки на вторую одним ходом.

Входные данные

Программа получает на вход четыре числа от 1 до 8 каждое, задающие номер столбца и номер строки сначала для первой клетки, потом для второй клетки.

Выходные данные

Программа должна вывести YES, если из первой клетки ходом слона можно попасть во вторую, или NO в противном случае.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
danilpov
02.05.2020 19:06

Важное замечание: Программа будет работать только при компиляции компилятором, поддерживающим стандарт C99.

#include <stdio.h>

#include <stdlib.h>


int compare(const int* A, const int* B); // компаратор для qsort

int main()

{

   int N;

   

   printf("Введите размер массива: ");

   scanf("%d", &N);

   

   int

       arr[N],

       sum = 0,

       number = 0;

   

   

   for(int i = 0; i < N; i++)

       scanf("%d", &arr[i]);

       

   for(int i = 0; i < N; i++)

       printf("%d ", arr[i]);

   printf("\n");

   for(int i = 0; i < N; i++)

   {

       if(arr[i])

           sum += arr[i];

       if((arr[i] % 3 == 0) && (i % 2 == 0))

           number += 1;

   }

   

   qsort(arr, N, sizeof(int), compare);

   

   for(int i = 0; i < N; i++)

       printf("%d ", arr[i]);

   

   

   printf("\nСумма положительных элементов = %d\n\

   количество элементов, имеющих четные порядковые номера и являющиеся нечетными числами = %d", sum, number);

   return 0;

}


int compare(const int* A, const int* B)

{

   return *A - *B;

}

0,0(0 оценок)
Ответ:
дэн165
22.06.2020 11:02
1. Неожиданная резкая боль, страх, нервные потрясения.
Они могут вызвать мгновенное снижение артериального давления, вследствие чего наступает снижение кровотока, нарушение кровоснабжения головного мозга, что приводит к обмороку.

2.Общая слабость организма, иногда усугубляемая нервным истощением.
Общая слабость организма, возникающая вследствие самых разных причин, начиная от голода, плохого питания и кончая постоянным волнением, может также привести к снижению артериального давления и обмороку.

3.Пребывание в помещении с недостаточным количеством кислорода.
Уровень кислорода может быть понижен из-за нахождения в помещении большого количества людей, плохой вентиляции и загрязнения воздуха табачным дымом. Вследствие этого мозг получает меньше кислорода, чем нужно, и у пострадавшего наступает обморок.

4.Длительное пребывание в положении стоя без движения. Это приводит к застою крови в области ног, уменьшению ее поступления в мозг и, как следствие, - к обмороку.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота