ЛордМирак
06.11.2021 06:04

На бесконечном поле имеются стены неизвестной длины. Напишите программу, закрапивающую клетки, указанные на рисунке.
Робот должен закрасить все клетки, прилегаюпие к горизонтальной стеве снизу (так. как это илображено на рисунке). Консчное положение Робота лначения не имеет.​


На бесконечном поле имеются стены неизвестной длины. Напишите программу, закрапивающую клетки, указа

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
228778anonim228778
08.04.2021 18:34
Var
    i, n, s: integer;

begin
    readln(n);
    i := 0;
    s := 0;
    
    while i < 7 do
    begin
        if (n mod 2 = 1) then begin
            s := s + n;
            i := i + 1;
        end;
        n := n + 1;
    end;
    
    writeln(s);
end.

var
    i, n, s: integer;

begin
    readln(n);
    i := 0;
    s := 0;
    
    repeat
        if (n mod 2 = 1) then begin
            s := s + n;
            i := i + 1;
        end;
        n := n + 1;
    until i >= 7;
    
    writeln(s);
end.

var
    i, n, s: integer;

begin
    readln(n);
    n := n + (n + 1) mod 2;
    s := 0;
    
    for i := 1 to 7 do
    begin
        s := s + n;
        writeln(n);
        n := n + 2;
    end;
    
    writeln(s);
end.
0,0(0 оценок)
Ответ:
12poli
08.04.2021 18:34

Основная идея состоит в том, что каждая сумма – это сумма цифр, то есть она не может быть больше 18. Значит, надо разбивать каждое возможно получившееся число на однозначные и двузначные числа и смотреть, может ли такое быть.

1212 – возможно, например, из числа 666 (6+6 = 12, 6+6 = 12, итог: 1212)

129 – возможно, например, из числа 936 (9+3 = 12, 3+6 = 9, итог: 129)

123 – возможно, например, из числа 930

1218 – невозможно. Это число можно разбить только на два двузначных числа, но тогда 12 и 18 записаны в порядке возрастания, а по условию должно быть наоборот

1812 – возможно, например, из числа 993

312 – невозможно. Это число можно разбить либо на 3 и 12, либо на 31 и 2. В первом случае числа расположены в порядке возрастания, а во втором нельзя получить 31, так как сумма цифр не больше 18

912 – невозможно (аналогично с 312)

112 – возможно, например, из 920

Итого 5 чисел могут получиться.

ответ: 5

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота