ikaerlapova
14.10.2021 13:04

Написать программу в паскале на тему "телефон доверия Типо такого​

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Alyona2022
26.08.2021 04:00

Вводятся координаты (x;y) точки и радиус круга (r). Определить принадлежит ли данная точка кругу, если его центр находится в начале координат.

Будем считать, что точка принадлежит кругу, если находится внутри его или на его окружности.

Из любой точки координатной плоскости можно провести отрезок к началу координат. Если длина этого отрезка больше радиуса круга, то точка лежит за пределами круга и, следовательно, не принадлежит ему. Если же отрезок, соединяющий точку и начало координат, меньше радиуса круга с центром в начале координат или равен ему, то точка будет принадлежать кругу.

0,0(0 оценок)
Ответ:
132132456789
17.02.2020 19:40
#include <iostream>using namespace std; int main(){     char str [] = "dd yhd yw dcjkayt dvqv auyj fbajk dyusdv sddw";     int k = 9; //position     int before=  0, after = 0, space = 0;                         for(int i = 0; i <= k; i++){             if(str[i] == ' '){                 space++;             }         }         if(str[k] != ' '){       for(int i = k + 1; str[i]; i++){         if(str[i] == ' ' || str[i] == '\0'){             after = i;                         break;                 }         }         for(int j = k - 1; j >= 0; j--){         if(str[j] == ' ' || j == 0){             before = j;                         break;                 }     }         cout<<space + 1<<" slovo ";         for(int i = before; i < after; i++)         cout<<str[i];         }         else cout<<space<<" slovo"; return 0; }
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота