sanyok505
23.08.2021 21:16

Составить программу, после выполнения которой на экране будет нарисована мишень из 5 окружностей. Размер выбрать произвольно. По братски

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
mstella2003
17.09.2020 10:57
#include <iostream>
#include <conio.h>
#include <time.h>
using namespace std;

void main()
{
 srand(time(NULL));
 setlocale(0, "");
 int arr[17];
 int a, b, chet=0, nechet = 0;
cout << "Введите диапазон ." << endl << "Нижняя граница диапазона: "; cin >> a; cout << "Верхняя граница диапазона: "; cin >> b; cout << endl;
for (int i = 0; i < 17; ++i)
{
  arr[i] = a + rand() % (b-a+1);
  cout <<" "<<arr[i];
}
for (int i = 0; i < 17; ++i)
{
  if (arr[i] % 2 == 0) chet++;
 else nechet++;
} if (chet > nechet)
 cout << " \n Четных больше";
else if (nechet>chet)
 cout << "\n Нечетных больше";
else cout << "\n Одинаковое количество четных и нечетных";
 _getch();
}
0,0(0 оценок)
Ответ:
mariana20021
22.04.2023 05:19
Const Sz = 1000; var   a: array [1..Sz] of integer;  b: array [1..Sz] of integer;  c: array [1..Sz] of integer;  d: array [1..Sz] of integer;  M: integer;  N: integer;  i: integer;  k: integer;begin  read(M);  readln(N);  for i:=1 to N do begin    read(a[i]);    readln(b[i]);    if (a[i]<>0) then c[i]:=1 else c[i]:=0;    end;  for i:=1 to N do begin  if(c[i]<>0) then begin  for k:=1 to i do begin  if(d[k]=0) then d[i]:=1;  if (c[k]=i) then d[k]:=0;   end;   writeln(d[i])  end;end;end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота