sofiyabashkaiki
15.01.2020 09:56

Составить программу, в которой посчитать кол-во гласных в строке. (в pascal)(тема: двумерные массивы)

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
KIrito5016
09.06.2020 11:37

program raf105;

var a:array[1..100,1..2] of char;

glas,s:string;

i,j,sumglas:integer;

begin

glas:='аеёиоуыэюя'; // Перечисление гласных

for i:=1 to length(glas) do

 a[i,2]:= glas[i]; //Заполнение второй строки для гласных

writeln('Введите строку');

readln(s);

for i:=1 to length(s) do

 a[i,1]:= s[i]; //Заполнение первой строки для введённых букв

for i:=1 to length(s) do

 for j:=1 to length(glas) do

   if a[i,1] = a[j,2] //если символ из строки 1 = символу из строки 2

     then sumglas:= sumglas+1; //Прибавление единицы к счётчику

writeln('В строке ',sumglas,' гласных');

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота