Samina7161
04.02.2020 20:11

Хелп,умоляю..написать программу для подсчёта количества чётных и нечётных цифр любого числа( в паскале), .​

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
ruslanantosyuk1
10.10.2020 02:39

var

   a, chet, nechet : integer;

   

begin

   write('введите число: ');

   readln(a);

   while a > 0 do begin

       if (a mod 10) mod 2 = 0then chet += 1 else nechet += 1;

       a := a div 10;

   end;

   writeln('четных: ', chet);

   writeln('не четных: ', nechet);

end.

программа считает 0 как четное число. Если нужно что бы 0 не учитывался при подсчете то необходимо строку:

if (a mod 10) mod 2 = 0then chet += 1 else nechet += 1;

заменить на:

if a mod 10 <> 0 then if (a mod 10) mod 2 = 0then chet += 1 else nechet += 1;

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота