Trasir
27.05.2021 04:02

Установил максимальное количество ! (100)

Напишите программу, которая в последовательности натуральных чисел определяет среднее значение между минимальным и максимальным для чисел кратных 5. Программа получает на вход натуральные числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 – признак окончания ввода последовательности, и в последовательность не входит). Введённые числа не превышают 30 000.Программа должна вывести одно число: среднее значение между минимальным и максимальным для чисел кратных 5 или вывести NO, если таких чисел в последовательности нет.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Maria9613
15.10.2020 03:21

Pascal?

var min, max, j, count: integer;

begin

min:=30000;

max:=0;

readln(j);

while j <> 0 do begin

if (j mod 5 = 0) and (j < min) then begin

min:= j;

count:= count + 1;

end;

if (j mod 5 = 0) and (j > max) then begin

max:= j;

count:= count + 1;

end;

readln(j);

end;

if count = 0 then write('NO') else write((min+max)/2);

end.

0,0(0 оценок)
Ответ:
gybshova
15.10.2020 03:21
                                 PascalABC.NET                                  begin var L := Lst(ReadArrInteger(1)); while L.Last <> 0 do L.Add(ReadlnInteger); L.RemoveAt(L.Count - 1); if (L.Min..L.Max).Count(x -> x mod 5 = 0) <> 0 then Println((L.Min..L.Max).Where(x -> x mod 5 = 0).Average) else Println('NO'); end.

Используется лишь одна переменная - список L.

Пример работо
Установил максимальное количество ! (100) Напишите программу, которая в последовательности натуральн
Установил максимальное количество ! (100) Напишите программу, которая в последовательности натуральн
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота