Напишите программу нахождения суммы и произведения 20 случайных чисел

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
tyy6
02.09.2022 08:19

1) 6

2) 1

Скобки меняют приоритет выполнения действий:

1) сначала выполнили деление, потом сложение

2) сначала выполнили сложение в скобках, потом деление

Объяснение:

A1 = 1, A2 = 4, B1 = 2 и B2 = 3.  

1) =A1+A2/B1+B2 = 1 + 4 / 2 + 3 = 1 + 2 + 3 = 6

2) =(A1+A2)/(B1+B2) = (1 + 4) / (2 + 3) = 5 / 5 = 1

Порядок выполнения действий в выражениях без скобок:  

1) действия выполняются по порядку слева направо

2) сначала выполняется умножение и деление, а затем - сложение и вычитание

Скобки меняют приоритет выполнения действий (действия в скобках выполняют первыми)

0,0(0 оценок)
Ответ:
Гарфилд32
11.02.2021 10:41

#include <iostream>

using namespace std;

int main() {

  int L, D, K;

  cin >> L >> D >> K;

  if (L % D == 0 && (K >= D || D - K == 1)) {

      cout << L / D;

  }

  else if (L % D == 0 && K < D && D - K > 1) {

      cout << K;

  }

  else if (L % D < D && K > D) {

      cout << D;

  }

  else if (L % D < D && K < D) {

      cout << D - K;

  }

  else if (L % D < D && K == D) {

      cout << D - 1;    

  }

  return 0;

}

Объяснение:

c++

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота