Волвлчлчлч
18.12.2022 01:17

Написать программу на языке паскаль для решения . с цикла с послеусловием напишите программу, которая требует у вас пароль, например, 111. если пароль правильный, то заполняет все строки экрана сообщением «молодец». если после пятой попытки пароль все равно неверен, выходит из программы. для проверки подготовить код программы и результаты ее работы.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
969758676
09.06.2020 09:56
Код программы:(пароль: 105)

program raf105;

const pass = 105;

var enterpass, x:integer;

begin

repeat

 write('Введите пароль: ');

 readln(enterpass);

 if enterpass = pass

   then

     while 1=1 do

       writeln('Молодец')

   else x += 1;

until x=5;

end.

Результаты работы программы:1.

Вывод: Введите пароль:

Ввод: 105

Вывод: Молодец Молодец Молодец Молодец Молодец Молодец Молодец Молодец Молодец...

2.

Вывод: Введите пароль:

Ввод: 123

Вывод: Введите пароль:

Ввод: 106

Вывод: Введите пароль:

Ввод: 0

Вывод: Введите пароль:

Ввод: 104

Вывод: Введите пароль:

Ввод: 666

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота