lina09270
15.09.2022 14:43

Используя оператор for напишите программу, которая выводит целые
числа в диапазоне от 1 до 25(включительно) с шагом 3.
2) Используя оператор while напишите программу, которая вычисляет
сумму всех четных чисел в диапазоне от 5 до 20.
3) Используя оператор while напишите программу, которая вычисляет
сумму всех нечетных чисел в диапазоне от 5 до

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Roma1971
06.04.2022 05:20

ответ:Program a10;

var a,b:Array [1..100,1..100] of integer;

k,i,n,j,s:integer;

Begin

read(n);

For i:=1 to n do

begin

For j:=1 to n do

begin

read(a[i,j]);

end;

end;

i:=0;j:=0;s:=0;k:=0;

while i<=n do

begin

i:=i+1;j:=j+1;

if(a[i,j]>0)then k:=k+1;

s:=s+a[i,j];

end;

writeln(k,' ',s);

end.

2)

Program a10;

var a,b:Array [1..100,1..100] of real;

k,i,n,m,j:integer;

s:real;

Begin

read(n,m);

For i:=1 to n do

begin

For j:=1 to m do

begin

read(a[i,j]);

end;

end;

k:=0;

for j:=1 to m do

begin

s:=0;

for i:=1 to n do

begin

s:=s+a[i,j];

end;

for i:=1 to n do

begin

if(a[i,j]>(s-a[i,j]))then k:=k+1;

end;

end;

writeln(k);

end.

Объяснение:

0,0(0 оценок)
Ответ:
TEmik777777777
03.07.2020 10:16

#include <iostream>

using namespace std;

int Vegetables(int month)

{

int cucumbers = 0;

for (int i = 0; i < month; i++)

{

 cucumbers += 5;

}

return cucumbers;

}

int decoration(int gold_amount, int gold_per_decoration)

{

int decor = 0;

while (gold_amount > 0)

{

 decor++;

 gold_amount -= gold_per_decoration;

}

return decor - 1;

}

int main()

{

setlocale(LC_ALL, "rus");

int month = 30, gold_amount = 3037, gold_per_decoration = 5;

 

cout << "В месяц, длинною в 30 дней, созревает " << Vegetables(month) << " огурцов" << endl;

cout << "Из " << gold_amount << " грамм золота, можно получить " << decoration(gold_amount, gold_per_decoration) << " украшений" << endl;

return 0;

}

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота