666SmEtAnKa666
30.09.2021 11:39

Наибольшее число
Напишите программу, которая определяет, есть ли во введённой строке десятичные цифры, и выводит наибольшее число, которое можно составить из этих цифр. Ведущих нулей в числе быть не должно (за исключением числа 0, запись которого содержит ровно одну цифру). Если цифр нет, программа должна вывести число −1.

Использовать встроенные сортировки запрещено.

Входные данные

Входная строка содержит произвольные символы.

Выходные данные

Программа должна вывести наибольшее число, которое можно составить из присутствующих в строке десятичных цифр, или число −1, если цифр нет.

Примеры
Ввод
Вывод
Day 10, mice 8: "Year" 7 is a mistake 91.
987110
Python

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
6506463
07.08.2022 14:24
2)
const 
N=8;
M=10;
var p:array[1..N,1..M] of integer;
i,j:integer;
begin 
for i:= 1 to N do   
for j:=1 to M do 
begin   p[i,j]:=i*j;  write(p[i,j],' ') 
end; 
end.

3)
const 
N=4;
M=6;
var z:array[1..N,1..M] of integer;
i,j,sum,pr:integer;
begin
randomize;sum:=0;
pr:=1; 
  for i:= 1 to N do   
   for j:=1 to M do   
begin z[i,j]:=random(100); 
 write(z[i,j],' ');   
 sum:=sum+z[i,j];   
 pr:=pr*z[i,j]; 
end; 
writeln(); 
write('сумма ',sum,' произведение ',pr); 
end.

4)
const 
N=5;
M=5;
var a:array[1..N,1..M] of integer;
i,j,sum,pr:integer;
begin
randomize;
sum:=0;
pr:=1; 
for i:= 1 to N do   
for j:=1 to M do   
begin
a[i,j]:=random(100);   
write(a[i,j],' ');   
sum:=sum+a[i,j];   
pr:=pr*a[i,j]; 
end; 
writeln(); 
write('сумма ',sum,' произведение ',pr); 
end.
0,0(0 оценок)
Ответ:
NwM12
04.03.2020 21:33
Const
  nn=20;
var
  d:array[1..nn,1..nn] of integer;
  zr,zc:array[1..nn] of boolean; { строки и столбцы }
  n,m,i,j,nr,nc:integer;
begin
  Write('Укажите n и m: '); Read(n,m);
  Randomize;
  Writeln('И с х о д н ы й   м а с с и в');
  nr:=0; nc:=0;
  for i:=1 to n do zr[i]:=False;
  for j:=1 to m do zc[j]:=False;
  for i:=1 to n do begin
    for j:=1 to m do begin
      d[i,j]:=Random(21)-10;
      Write(d[i,j]:4);
      if d[i,j]=0 then begin zr[i]:=True; zc[j]:=True end;
      end;
    Writeln
    end;
  for i:=1 to n do
    if zr[i] then
      for j:=1 to m do d[i,j]:=0;
  for j:=1 to m do
    if zc[j] then
      for i:=1 to n do d[i,j]:=0;
  Writeln('М а с с и в - р е з у л ь т а т');
  for i:=1 to n do begin
    for j:=1 to m do Write(d[i,j]:4);
    Writeln
    end
end.

Пример
Укажите n и m: 7 12
И с х о д н ы й   м а с с и в
 -10   8  -4  -3  -8   9   1  -6   4  -6   5  -1
  -8  -2  -8  -7  -3  -1   4   4   5  -1   7  -6
   8  -5   8  -1  -8   9   8  -4  -6  -2   0   4
   7  -4   8  -9   3   2   9   3   3   6   9   4
   9  -3   8   8  -4   9   7   2 -10  -8  -1   8
 -10  -8  -8   6  -4  -2  -6   4   8  -1  -3  -9
   2   2  -9  -7   0  -6   2  -9  -4  -6   0   5
М а с с и в - р е з у л ь т а т
 -10   8  -4  -3   0   9   1  -6   4  -6   0  -1
  -8  -2  -8  -7   0  -1   4   4   5  -1   0  -6
   0   0   0   0   0   0   0   0   0   0   0   0
   7  -4   8  -9   0   2   9   3   3   6   0   4
   9  -3   8   8   0   9   7   2 -10  -8   0   8
 -10  -8  -8   6   0  -2  -6   4   8  -1   0  -9
   0   0   0   0   0   0   0   0   0   0   0   0
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота