kozlovadasa52
22.09.2022 01:42

5.Программа получает на вход натуральное число N (3 ≤ N ≤100, N - нечетное). Выведите на экран таблицу размером NxN, средний столбец и средняя строка которой заполнены единицами, все остальные элементы нули.Язык Питон подалуйста​

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
natalinatark
14.10.2020 23:20

n = int(input())

a = [['0'] * n for i in range(n)]

for i in range(n):

    for j in range (n):

         a[i][n//2] = '1'

         a[n//2][j] = '1'

for l in a:

    print(*l)  

Объяснение:

С цикла for сначала закрашивается вертикаль, потом горизонталь

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота