Smartfone
14.07.2020 14:51

Напишите программу, которая выводит на экран таблицу степеней двойки. Рекомендуемый вид экрана после выполнения программы:
Таблица степеней двойки:
0 1
1 2
2 4
3 8
4 16
5 32
6 64
7 128
8 256
9 512
10 1024

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
sofiotap3
14.10.2020 22:13

Python:

for i in range(11):

   print(i, 2**i)

Pascal:

program hw;

var  

   i:integer;

function powq(a, b: integer):integer;

   var i: integer;

   begin

   powq := 1;

   for i := 1 to b do  

       powq := powq * a;

   end;

begin

   for i := 0 to 10 do

       writeln (i, ' ',powq(2, i));

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота