barbara27
14.03.2021 18:19

Уровень - Анализ Составьте программу, которая определяет, принадлежит ли
точка хотрезку [А;B]. Если точка принадлежит отрезку
[A;B], то выводится ответ - Yes, а иначе - No.
Создать программу на языке программирования Python

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
katongop0107l
03.10.2020 22:31

#include <iostream>

#include <iomanip>

using namespace std;

int main() {

int max, index;

max = 0;

index = -1;

int arr[3][5] = { { 3, 0, 3, 0, 5} , { 5, 3, 0, 2, 0} , { 4, 0, 3, 2, 1} };

for (int i = 0; i < 3; ++i){  // вывод исх. матрицы, можешь удалить, если надо.

 for (int j = 0; j < 5; ++j){

  cout << setw(3) << arr[i][j];

 }

cout << endl;

}          // до этой строки вывод исх. матрицы

int tmp = 0;

for (int j = 0; j < 5; j++){  // подсчет нулей

  for (int i = 0; i < 3; i++){

   if (arr[i][j] == 0){

    tmp++;

   }

  }

  if (tmp > max){   // тут получаем номер столбца, в котором

   max = tmp;  // больше всего нулей

   index = j;

  }

  tmp = 0;

 }

cout << endl << "" << endl;

if (index != -1){

 for (int i = 0; i < 3; i++){

  arr[i][index] = -2;

 }

}

for (int i = 0; i < 3; ++i){  // вывод измененной матрицы

  for (int j = 0; j < 5; ++j){

   cout << setw(3) << arr[i][j];

  }

 cout << endl;

 }

return 0;

}

0,0(0 оценок)
Ответ:
benslip13
24.11.2021 22:41
1 множество будет называться :
"Ученики 7 "А" класса школы 10 Санкт-Петербурга".
В него будет входить ученик этого класса Вася Петров, ученица Полина Панова и другие ученики в классе 7 "А" в школе #10 Санкт-Петербурга.
2 множество будет называться :
"Учителя школы #5 Москвы".
В него будут входит все учителя, включая учительницу школы #5 в Москве- Ольга Николаевну, Марину Васильевну и других...
3 множество будет называться :
"Отличники 9 "Б" класса школы #21 Твери".
В него будут входить все отличники 9 "Б" класса школы #21 города Твери. Вася Пакин, Ульяна Иванова и др.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота