elsem78
27.04.2021 02:01

Напишите программу, которая 4 раз выводит на экран ваши имя и фамилию.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
rutasolntseva
15.08.2022 15:18

ответ:

. в нужно вывести все составные числа из промежутка [2; n]. код программы:

program lab3;

var i,n,j,s,l: integer;

m: real;

begin

readln (n);

for i: =2 to n do

begin

s: =trunc (sqrt (i));

for l: =2 to s do

begin

m: = i mod l;

if m=0 then

write (' ',i);

end;

end;

end.

но проблема - как только s становится больше 2, составные числа начинают несколько раз повторятся, т.к., например 12 делится и на 2 и на 3. вопрос: как мне сделать выход из цикла после первого успешного деления?

var

i, n, j, s, l: integer;

m: real;

begin

readln(n);

for i : = 2 to n do

begin

s : = trunc(sqrt(i));

for l : = 2 to s do

begin

m : = i mod l;

if m = 0 then

begin

write(' ', i);

break;

0,0(0 оценок)
Ответ:
Tipudi228
04.09.2022 02:49
A) 9x-2=5x-2               г)53-6x=4x-17 9x-5x=-2+2                   -6x-4x=-17-53 4x=0                           -10x=-70 x=0                             10x=70 б)10-3x=2x-15               x=7 -3x-2x=-15-10               д)8+2x=16+x -5x=-25                           2x-x=16-8 5x=25                             x=8 x=5 в)10x+7=8x-9 10x-8x=-9-7 2x=-16 x=-8
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота