ivanermilov200
17.02.2022 15:46

С40 . напишите программу полностью исправленную в этой ошибки. begin var f: real-> real : = x -> (0.1 * (sin(x) / cos(x)) * (0.1 * x + (0.0025 * x * ; var (a, b) : = readreal2('введите границы интервала: '); var (fa, fb) : = (f(a), f(b)); var eps : = readreal('введите требуемую точность: '); var n : = 1; writeln(' n', 12 * ' ', 'x', 14 * ' ', 'y'); while true do begin var x : = (a + b) / 2; var y : = f(x); if (abs(y) < eps) and (abs(b - a) < eps) then break; writeln(n: 3, x: 15: 6, y: 15: 6); if sign(fa) = sign(y) then a : = x else b : = x; n += 1 endend.​

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
arseniyrom20p08lxy
05.05.2023 09:12

Теоретический материал (Паскаль)

Понятие двумерного массива. Описание типа массива. Формирование значений элементов массива случайным образом

Одним из основных направлений использования компьютеров является накопление и обработка данных - различных таблиц, справочников, словарей и другой информации. Для представления такой информации в программе удобно использовать массивы. Как правило, обработка таких данных осуществляется по одному и тому же закону, для чего удобно использовать циклические алгоритмы.

Мы уже рассматривали формирование и обработку одномерных массивов. Вспомним, что в массив мы объединяем конечную последовательность компонентов одного типа и даем им общее имя. Каждый отдельный компонент массива называется элементом. Количество элементов называется размером массива. Тип элементов определяет тип массива. Размер и тип массива указываются при его описании, причем размер может быть указан либо конкретным значением, либо ранее определенной константой. Номер элемента называется индексом. Индексы могут быть целыми положительными константами или целыми переменными. Чтобы обратиться к некоторому элементу массива, нужно рядом с идентификатором массива в скобках указать индекс элемента.

Но часто данные могут быть организованы в виде таблицы (матрицы), где расположение каждой переменной определяется номером строки и номером столбца. Например, место в зрительном зале задается указанием номера ряда и номером места в этом ряду. Такие данные удобно описать как двумерный массив. В отличие от одномерного массива каждому элементу двумерного массива соответствует пара индексов. Первый индекс - это номер строки, а второй - номер столбца, где расположен элемент массива.

Размер двумерного массива задается парой чисел: M*N, где M - число строк, а N - число столбцов в таблице.

Пусть задан двумерный массив Matr, имеющий размер 10*20. Этот массив на языке Паскаль может быть описан следующим образом:

Var

Matr : array [1..10,1..20] of integer;

0,0(0 оценок)
Ответ:
oleglebedev90
21.10.2020 20:31

var

 a: array of integer;

 n, i, maxpar, minn: integer;

begin

 Write('Введите размер массива N: '); ReadLn(n);

 SetLength(a, n);

 randomize;

 minn := 51;

 WriteLn('Массив:');

 for i := 0 to n - 1 do

 begin

   a[i] := random(50) + 1;

   Write(a[i], ', ');

   if (a[i] < minn) and (a[i] mod 2 = 1) then minn := a[i];

 end;

 WriteLn;

 Sort(a);

 for i := 0 to n - 2 do

   if a[i] = a[i + 1] then maxpar := a[i];

 if maxpar <> 0 then WriteLn('Максимальный парный элемент равен ', maxpar)

    else WriteLn('В массиве нет парных элементов');

 WriteLn('Минимальный нечетный элемент равен ', minn);

end.

Объяснение:

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота