Войти
Регистрация
Спроси ai-bota
АняМур123
18.12.2021 04:55
решить данные задания в Паскале
Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
longassride
08.02.2021 03:31
Решить : 1) коля достал красную карту из колоды, в которой было 16 черных и 8 красных карт. сколько информации он получил? 2) вася получил смс от коли «купил игру. играем...
wiamous1
08.02.2021 03:31
Склавиатуры задано целое число n 5.если оно положительное. то вывести на экран его название в словесной форме.в противном случае найти квадрат этого числа. ,9 класс...
MIshaDo
24.04.2022 05:40
Задача1: Рассчитать объём памяти в мегабайтах, необходимой для представления двухминутного фильма на экране монитора с разрешением 1024х768 пикселей и палитрой из 1024...
Olena0012
22.10.2021 12:55
1. Почему сжатие с потерями используется в основном как кодирование изображений и звука? 2. Поясните суть методов «кодирования повторов» и кодирование по Лемпелю-Зиву....
homya4okm
29.01.2021 07:29
Написать 2 программы: 1.Программа получает на вход 2 числа(2 катета). Выводит на экран гипотенузу и площадь прямоугольного треугольника. 2. Программа находит минимальное...
Xbdjdndskej
29.01.2021 07:29
Определить расстояние на плоскости между двумя точками с заданными координатами. Составьте блок-схему и напишите программу...
nastyacrew
06.12.2021 16:33
опредили к какому числу относятся двоичные коды:10.000,10001,10010,10011,10100...
sacredand
12.12.2022 11:12
Как можно улучшить программное обеспечение?...
violetta238
10.10.2021 01:50
Сколько состояний можно запомнить с одного байта...
kris411
05.02.2021 14:15
Имеется n количество шариков. для каждого шарика известен диаметр. определить количество шариков с диаметром 5 см....
Ответ:
ХАМЕЧОКЕ2036
30.11.2021 11:48
1)var n,k: integer; begin write('число: '); readln(n); k: =0; repeat k: =k*10+n mod 10; n: =n div 10; until n=0; writeln('новое число: ',k); end. 2) var n,k,m: integer; begin write('двоичное число: '); readln(n); k: =1; m: =0; repeat m: =m+k*(n mod 10); n: =n div 10; k: =k*2; until n=0; writeln('десятичное число: ',m); end.
0,0
(0 оценок)
Ответ:
stebone
30.11.2021 11:48
1000 = 2^3*1 + 2^2*0 + 2^1*0 + 2^0*0 = 8 + 0 + 0 + 0 = 8
0001 = 2^3*0 + 2^2*0 + 2^1*0 + 2^0*1 = 0 + 0 + 0 + 1 = 1
0110 = 2^3*0 + 2^2*1 + 2^1*1 + 2^0*0 = 0 + 4 + 2 + 0 = 6
0001 = 2^3*0 + 2^2*0 + 2^1*0 + 2^0*1 = 0 + 0 + 0 + 1 = 1
0101 = 2^3*0 + 2^2*1 + 2^1*0 + 2^0*1 = 0 + 4 + 0 + 1 = 5
0100 = 2^3*0 + 2^2*1 + 2^1*0 + 2^0*0 = 0 + 4 + 0 + 0 = 4
1001 = 2^3*1 + 2^2*0 + 2^1*0 + 2^0*1 = 8 + 0 + 0 + 1 = 9
Если это одно большое число, то вот так
1000000101100001010101001001 = 2^27*1 + 2^26*0 + 2^25*0 + 2^24*0 + 2^23*0 + 2^22*0 + 2^21*0 + 2^20*1 + 2^19*0 + 2^18*1 + 2^17*1 + 2^16*0 + 2^15*0 + 2^14*0 + 2^13*0 + 2^12*1 + 2^11*0 + 2^10*1 + 2^9*0 + 2^8*1 + 2^7*0 + 2^6*1 + 2^5*0 + 2^4*0 + 2^3*1 + 2^2*0 + 2^1*0 + 20*1 = 134217728 + 0 + 0 + 0 + 0 + 0 + 0 + 1048576 + 0 + 262144 + 131072 + 0 + 0 + 0 + 0 + 4096 + 0 + 1024 + 0 + 256 + 0 + 64 + 0 + 0 + 8 + 0 + 0 + 1 = 135664969
^ - Возведение в степень
0,0
(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота