Abrak24
08.01.2023 01:25

Написать программу для нахождения суммы чёрных элементов массива не оканчивающихся на ноль. ИНФОРМАТИКИ МНОГО

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
vimeworldru
14.10.2020 20:49

const Sz = 10000;

var

 a: array [1..Sz] of integer;

 N: integer;

 i: integer;

 sum: integer;

begin

 sum := 0;

 write('Введите количество элементов в массиве: ');

 readln(N);

 write('Введите элементы массива: ');

 for i:=1 to N do

 begin

   read(a[i]);

   if (a[i] mod 2 = 0) then

   begin

       if (a[i] mod 10 <> 0) then

       begin

           sum := sum + a[i];

       end;

   end;

 end;

   

 write('Сумма элементов: ', sum);

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота