Лидуня270516
29.10.2022 17:19

Составьте программу для вычисления y=tgx+x²+|z|​

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Единорожка2306
29.05.2020 00:30

1. Умножить на 2 2. вычесть b

Выполняя первую из них ,Вычитатель увеличивает число на экране в 2 раза ,а выполняя вторую,уменьшает это число на d.Программа для исполнителя Вычитатель - это последовательность номеров команд.Известно,что программа 22122 переводит число 30 в число 0.Определите значение b (b≥2).

30-x)-x)*2)-x)-x)=60-4x-x-x=60-2x

60-2x=0

-2x=-60

2x=60

x=30

ответ 30

1. Прибавь 1 2.возведи в квадрат

Исполнитель работает только с натуральными числами .Составьте алгоритм получения из числа 1 числа 100,содержащий не более 5 команд

1+1)+1)^2)+1)^2)=3^2=9+1=10^2=100

11212

ответ 11212

Объяснение:

0,0(0 оценок)
Ответ:
Danielkz02
31.12.2021 11:01

1

var

mas:array[1..100] of integer;

i,n:integer;

en,out:text;

res:real;

qw,qwe:string;  

begin

 n:=0;

 i:=1;

 write('Введите полный путь к импортируемому файлу: ');readln(qw);

 write('Введите полный путь к экспортируемому файлу: ');readln(qwe);

 assign(en,qw+'.txt'); assign(out,qwe+'.txt');  

 reset(en); rewrite(out);

 while not Eof(en) do    

 begin

 readln(en,mas[i]);      

 n:=n+mas[i];                

 inc(i);        

 end;

   res:=(n/(i-1));  

   write(out,res);  

   close(out);      

   close(en);

 end.

Там во вторую тупо добавляешь:

 max:=-100001;

 min:=100001;

if (mas[i]<0) and (mas[i] mod 2 = 0) and (mas[i]<min) then min:=mas[i];

 if (mas[i]>0) and (mas[i] mod 2 = 1) and (mas[i]>max) then max:=mas[i];  

if (max=-100001)or(min=100001) then writeln(out,'ERROR: please, rewrite yor file')

 else  

 begin

   writeln(out,min);

   writeln(out,max);  

Тоже такие же задачи решал)) лол). Ты не из 604??)))

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота