kazakstanarmy
15.06.2021 21:11

Напишите программу, которая в последовательности натуральных чисел определяет сумму всех положительных чисел, меньших 20 . программа получает на вход натуральные числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 решить 2-мя через while и через repeat. зарание

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
муслима18
09.06.2020 01:51

Через Repeat :

Var i, s:Integer ;

Begin

I:=1;s:=0;

Write(' Введите последовательность чисел') ;

Repeat

Read(i) ;

If (i>0)and(i<20)then s:=s+i;

Until i=0;

Writeln;write(s) ;

End.

Через While

Var i, s:Integer ;

Begin

I:=1;s:=0;

Write(' Введите последовательность чисел') ;

While i<>0 do begin

Read(i) ;

If (i>0)and(i<20) then s:=s+i;

End;

Writeln;write(s) ;

End.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота