Logikahaha
27.03.2023 00:09

Написать программы в pascalabc 1. даны два числа. удвойте большее число, утройте меньшее число. 2. у васи было 300 рублей. он решил купить несколько шоколадных батончиков по некоторой цене. хватит ли у него денег? напишите программу, которая запрашивает количество батончиков и цену батончиков. в результате должен появиться ответ "хватит денег" или "не хватит денег" и сколько денег останется в случае, если денег хватит. если же денег не хватит, то вывести, какой суммы не достает.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
ershvik781
30.09.2020 14:44

Объяснение:

1.

var a, b: integer;

begin

read(a, b);

if a < b then

begin

a := a * 3;

b := b * a

end

else

begin

a := a * 2;

b := b * 3;

end;

print(a, b);

end.

2.

var kol, cen: integer;

begin

writeln('Введите количество и цену');

read(kol, cen);

if kol * cen < 300 then writeln('Хватит денег')

else writeln('Не хватит ', kol*cen - 300, ' рублей.')

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота