AnnaFruzanna
17.03.2021 21:07

1. Ниже приведена программа:

var s,k: integer;
begin
readln(s);
readln(t);
if (s < 1) and (t < 2)
then
writeln ('YES')
else
writeln ('NO')
end.
Было выведено 9 запусков программы, при которых в качестве значений переменных вводились следующие пары чисел (s, t):

(3, 5); (4, 3); (4, −5); (0, 7); (0, −2); (−2, 1); (−2, 5); (−2, −4); (1, 2).

Сколько было запусков, при которых программа напечатала «NO»? В качестве решения выпишите все пары запусков и напротив каждого укажите вывод: YES или NO. В ответе укажите количество.

2. Составьте программу, выводящую значение вещественной переменной x, равной значению выражения 2(a+b)/a^2,где a и b – целочисленные переменные, их значения вводятся с клавиатуры.

3. Целое положительное число вводится с клавиатуры. Нужно проверить является ли оно четным.

4. Напишите программу, которая вычисляет сумму n-первых целых положительных чисел S = 1 + 2 + 3 + … + n. Количество суммируемых чисел n должно вводиться пользователем во время работы программы.​

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
13alla68
02.02.2021 00:43
Program a;
var s: array of integer;
x,n,p,sum,max,min,i,k,o,m:integer;
begin
p:=1;
sum:=0;
m:=-1;
o:=-1;
max:=-MaxInt;
min:=MaxInt;
Write('n= ');
read(n);
setlength(s,n);
Writeln('Перечислите значения:');
for x:=0 to n-1 do begin
read (s[x]);
k:=s[x];
if (k>0) and ((k mod 5) =0) then sum:=sum+k;
if ((k mod 10)=0) and (k>max) then begin max:=k; o:=x; end;
if ((k mod 2) = 0) and (k<min) then begin min:=k; m:=x; end;
end;Writeln('Сумма = ',sum);
if (ABS(o-m)=1) or (o=m) or (o=-1) or (m=-1) then write('Диапазон не найден') 
else begin
if (o>m) then
for i:=m+1 to o-1 do
p:=s[i]*p
else 
for i:=o+1 to m-1 do
p:=s[i]*p;
writeln('Произведение = ',p);
end;
end.
0,0(0 оценок)
Ответ:
Dffc
21.02.2020 17:40

1) полная таблица истинности каждого выражения с пятью переменными содержит 2^5 = 32 строки;

2) в каждой таблице содержится по 4 единицы и по 28 нулей, ( то есть 32-4);

3) выражение a v - b равно нулю тогда, когда a = 0 или b = 1;

4) min количество единиц в таблице истинности выражения a v - b будет тогда, когда там будет наибольшее число нулей, то есть в max количество строк одновременно a = 0 и b = 1;

5) по условию a = 0 в 28 строках, и b = 1 в 4 строках, поэтому выражение a v - b может быть равно нулю не более чем в 4 строках, а оставшиеся 32 – 4 = 28 могут быть равны 1.

ответ: 28.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота