Марина1000001
05.11.2020 00:56

Контрольная работа №4 «Программное управление работой компьютера»
Часть А
Во Что из указанного НЕ входит в алфавит языка Паскаль?
1) латинские буквы
2) служебные слова
3) русские буквы
4) знаки арифметических действий
Во Какая строка из перечисленных описывает вещественную переменную на
языке Паскаль?
Var x: integer;
Var x: Boolean;
Var x: real;
Var x: stringl
Во Как записывается оператор вывода?
Writeln ( )
Readln( )
While ( )
Begin ( )
Во Укажите условие выбора чисел, кратных 5 и не кратных 10:
(X mod 5=0) and (X mod 10<>0);
(X mod 5<>0) or (X mod 10=0);
(X mod 5=0) and (X mod 10=0)
Во Чем характеризуется переменная?
Именем, типом, значением
Типом, значением
Именем, значением
Во Сколько раз повторится тело цикла в процессе выполнения фрагмента
программы:
k:= 8;
while k<20 do k:=k+10;
8
6
2
10
Во Операторы в Паскале разделяются:
запятой
переходом на новую строку
точкой с запятой
точкой
Во Какой оператор в Паскале служит для выбора одного из двух вариантов
действий?
оператор ввода
оператор вывода
условный оператор
оператор цикла
Во Какое значение примет переменная Х после выполнения оператора
Х=17div2?
8.5
1
8
19
Во Оператор цикла с заданным числом повторений в Паскале имеет следующий
формат:
While <выражение> do <оператор>;
For <параметр>:=<начальное значение> to <конечное значение> do
Repeat <оператор> until <выражение>
Часть Б
1. В программе «:=» обозначает оператор присваивания; знаки «+», «−», «*»
и «/» − соответственно операции сложения, вычитания, умножения и
деления. Правила выполнения операций и порядок действий соответствует
правилам арифметики.
Определите значение переменной а после выполнения алгоритма:
a := −12
b := 14 − a / 2
b := (b − a) / 8
a := b * 2 + 6
В ответе укажите одно целое число − значение переменной а.
2. Запишите значение переменной s, полученное в результате работы следующей программы.
Var s,k: integer;
Begin
s := 8;
for k := 3 to 8 do
s := s + 8;
writeln(s);
End.
3. В таблице Dat хранятся данные измерений среднесуточной температуры за
10 дней в градусах (Dat[1] — данные за первый день, Dat[2] — за второй
и т. д.). Определите, какое число будет напечатано в результате работы сле-
дующей программы.
Var k, m: integer;
Dat: array[1..10] of integer;
Begin
Dat[1] := 12; Dat[2] := 15;
Dat[3] := 17; Dat[4] := 15;
Dat[5] := 14; Dat[6] := 12;
Dat[7] := 10; Dat[8] := 13;
Dat[9] := 14; Dat[10] := 15;
m := 0;
for k := 1 to 10 do
if Dat[k] > 12 then
begin
m := m + 1;
end;
writeln(m);
End.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
СветаВета
08.07.2022 00:29
AnsiChar  Символьный тип, гарантированный размер 8 бит 0.. 255
WideChar Тип переменной содержащий отдельный Интернациональный символ 0,,65535
Char Переменная этого типа занимает 1 байт и принимает одно из 256 значений кода ASCII
Real48 Тип с плавающей запятой с самой высокой вместимостью и точностью
Single Занимает 4 байта 1.5*10^{-45}..3.4*10^{38}
Double Занимает 8 байт 5.0*10^{-324}...-1.7*10^{308}
Extended Занимает 10 байт 3.4*10^{-4932}...1.1*10^{4932}
Comp Занимает 8 байт -2*10^{63} +1...+2*10^{63} -1
Currency Занимает 8 байт −922337203685477.5808...922337203685477.5807 
Real - для записи вещественных чисел 

P.S. Надеюсь на благодарность и лучший ответ.
0,0(0 оценок)
Ответ:
MtDew557723
18.12.2020 09:42
1. Переведите в байты:
560 бит = 560:8 = 70 байтов
3024 бита = 3024:8 =378 байтов
2. Переведите в биты:
540 байтов = 540*8 = 4320 бит
2,5 Кб = 2,5*1024*8= 2560*8 =  20480 бит
2 Гб = 2*1024*1024*1024*8 = 171798184 бита
3. Переведите в килобайты:
1024000 бит = (1024000:8):1024 = 125 Кб
9240 байтов = 9240:1024 ≈ 9,02  Кб
4. Заполните пропуски числами:
а) 3, 5 Кбайт = 3584 байт = 28672 бит
б) 3, 5 Гбайт = 3584 Мбайт = 3670016 Кбайт
Задача 1 
N=256 \\ N=2^i \\ i=8 \\ K=39 \\ I=K*i=312
ответ: 312 бит
Задача 2
K=v*t=250*40=10000 \\ N=64 \\ N=2^i \\ i=6 \\ I=K*i=10000*6=60000(bit)=7500(bait)=7,3 (Kbait)
ответ: 7,3 Кбайт
Задача 3
K_1=60*40=2400 \\ i=8(bit)=1(bait) \\ I=1280(Kbait)=1310720(bait) \\ I=K*i \\ 1310720=K_1*K_2*i=2400*K_2 \\ K_2=546,13=547
ответ: 547
Задача 4
N=2^i \\ 2^i=256 \\ i=8(bit)=1(bait) \\ I=1/32(Mbait)=1024/32(Kbait)=32(Kbait)=32*8(bait)=32768(bait) \\ K=I/i=32768/1=32768
ответ: 32768
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота