Имра11111
15.11.2021 02:59

напишите программу на паскаль программе на вход подаются 2 натуральных числа первое F количество футов второе д количество дюймов программа должна вывести строку содержащую вещественное число равное количество метров в футах и дюймах формат числа 2 знака после запятой пример строки вывода переведён текстовые данные 6 2 6'2" = 1,88т ответе перед и после знака "=" равно один пробел после количество футов одинарная кавычка после дюймов двойная кавычка​

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
musaevakhadizh
21.02.2021 11:14

program Chernovik;

var f,d:integer;

begin

read (f,d);

writeln(f,,d,,' = ',(d/12+f)*0.3048:0:2)

end.

Объяснение:

При удвоении символа ' Паскаль перестаёт воспринимать его как служебный символ

1 фут = 12 дюймов

1 фут = 0,3048 м

Форматированный вывод - после второго двоеточия указывается количество символов после запятой

Если нужно указать переменную для вещественного числа:

program Chernovik;

var f,d:integer;

m:real;

begin

read (f,d);

m:=(d/12+f)*0.3048;

writeln(f,,d,,' = ',m:0:2)

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота