Loxswe
21.11.2022 16:18

Напишите программу на языке Pascal, которая вычисляет среднее арифметическое всех четных чисел в диапазоне от 1 до n. (n вводится с клавиатуры и равна 8).

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
1000Умник
30.03.2023 18:22
// PascalABC.NET 3.3, сборка 1579 от 18.11.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var x:=ArrGen(8,i->Ln(i+1.1)); x.Println;
  var k:=x.Where(t->(Sin(t)>-0.5) and (Sin(t)<=0)).Count;
  var im:=x.IndexMin;
  Writeln('На указанном интервале найдено элементов: ',k);
  Writeln('Минимальный элемент массива, равный ',x[im],
      ' имеет порядковый номер ',im+1)
end.

Результат
0.0953101798043249 0.741937344729377 1.1314021114911 1.41098697371026 1.62924053973028 1.80828877117927 1.96009478404727 2.09186406167839
На указанном интервале найдено элементов: 0
Минимальный элемент массива, равный 0.0953101798043249 имеет порядковый номер 1
0,0(0 оценок)
Ответ:
Nerror
10.04.2022 09:54
ОТДЕЛ Задание+;
ИСПОЛЬЗУЕТ Вывод ИЗ "...\Отделы\Обмен\", Матем ИЗ "...\Отделы\Числа\";

ПЕР
  a, b: РЯД 10 ИЗ ЦЕЛ;
  сч: ЦЕЛ;

УКАЗ
  ОТ сч := 0 ДО РАЗМЕР(a) - 1 ВЫП
    a[сч] := УЗК(ВШИРЦЕЛ(Матем.случ() * 9)) + 1
  КОН;
  ОТ сч := 0 ДО РАЗМЕР(b) - 1 ВЫП
    ЕСЛИ ЧЕТ(сч) ТО
      b[сч] := a[сч] * 2
    ИНАЧЕ
      b[сч] := a[сч] * 3
    КОН
  КОН;
  ОТ сч := 0 ДО РАЗМЕР(a) - 1 ВЫП
    Вывод.ЧЦел("%d ", a[сч], 0, 0, 0)
  КОН;
  Вывод.Цепь("^");
  ОТ сч := 0 ДО РАЗМЕР(b) - 1 ВЫП
    Вывод.ЧЦел("%d ", b[сч], 0, 0, 0)
  КОН

КОН Задание.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота