MorozilkAAA
24.10.2022 08:03

Ii тограммирование»
вариант
1. в программе описан одномерный целочисленный массив асиплексами от 0 до 10
ниже представлен фрагмент этой программы, записанный на языке pascal, в
котором значения элементов массива сначала заднотся, а затем меняются
for i: =0 to 10 do
a[0]: =i+3;
for i: =10 downto 1 do
a[i-1]: = a[i]);
чему будут равны элементы утого массива после выполнения
программы?
того фрагмента
2 значения двумерного массива дразмера 8х8 залаioтся с воженного
оператора цикла в представленном фрагменте программы
for i: =1 to 8 do
for j: =1 to 8 do
a[i]: =ii-i;
сколько элементов массива а будут равны нулю?
3. в программе описан одномерный целочисленный массив ас индексами от 0 до 10
hске представлен фрагмент этой программы, записанный на языке pascal, в
котором значения элементов массива сначала , а затем меняются
for i: =0 to 10 do
a[i]: =i+2;
for i: = 0 to 10 do
begin
а(10-i]: = a[i]:
a[i] = а(10-і);
end;
чему будут равны элементы этого массива после выполнения того фрагмента
программы?
4. var x,y: string, l: byte;
begin
х='информация,
y='автоматика".
delete(x,6,5);
delete(y,1,4);
1: =length(x+y):
write (z);
чему будет равна переменная 7 после выполнения того фрагмента программы?
5. составьте программу подсчета суммы всех отрицательных элементов заданного це-
лочисленного массива размером 30 элементов если отрицательных элементов нет
сообщите об этом (элементы массива произвольные целочисленные числа, которые
вводит пользователь).
7. дана исходная строка (вводиться с клавиатуры) составьте программу, которая
подсчитывает количество букв «b» в этой строке.​

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
stolbov2005
08.05.2022 08:01

#include <iostream>

#include <vector>

using namespace std;

void bubbleSort(vector<int> &a_){

   vector<int> t;

   int n = a_.size();

   for(int i = 0; i < n; i++)

       for(int j = 0; j < n - i - 1; j++)

           if(a_[j] > a_[j + 1])

               swap(a_[j], a_[j + 1]);

   for(auto &i: a_) if(i & 1) t.push_back(i);

   a_ = t;

}

void solve(){

   vector<int> a = {2, 10, 5, 3, 11, 9, 12};

   bubbleSort(a);

   cout << "a = {";

   for(int i = 0; i < a.size() - 1; i++)

       cout << a[i] << ", ";

   cout << a.back() << "}";

}

int main(){

   solve();

}

0,0(0 оценок)
Ответ:
GooodBaby
12.06.2021 21:34

А. Устройство, с которого изображение выводится на монитор - 6. Видеокарта

В. Вентиляторы, предназначенные для воздушного охлаждения процессора - 7. Кулеры

С. Устройство, используемое для хранения всех видов данных - 1. Жёсткий диск

D. Устройство, которое позволяет создавать локальную сеть, соединяя компьютеры между собой и/или выходить в интернет - 4. Сетевая карта

E. Устройство, отвечающее за обработку звука на ПК - 3. Звуковая карта

F. Устройство, которое отвечает за обработку всех данных в системе и глобально управляет работой аппаратного обеспечения компьютера - 2. Процессор

G. Сложная многослойная печатная плата, на которой устанавливаются основные компоненты персонального компьютера - 5. Материнская плата

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота