2dybala1
19.03.2021 04:36

2. Напишите программу, которая по введённым пользователем положительным числам ведёт подсчёт чётных и нечётных, до того момента, пока пользователь не введёт ноль или отрицательное число. Используйте while или repeat на ваше усмотрение.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Kateriна
15.03.2023 09:40
Static void Main(string[] args) 
       {
            int[,] arr = new int[3, 3];
            Random c = new Random(DateTime.Now.Millisecond);
            for (int i = 0; i < 3; i++)                           
                     for (int j = 0; j < 3; j++)
                          arr[i, j] = c.Next(1, 9);          //заполнение матрицы
                                                                   //тебе это не надо, т.к. она дана           
            //заданный интервал
            int a = 3;
            int b = 3;
            int sum = 0;
            int proizvedenie = 1;
            for (int i = 0; i < a; i++)
            {
                for (int j = 0; j < b; j++)
                {
                    sum += arr[i, j];
                    proizvedenie *= arr[i, j];
                }
            }
            Console.WriteLine("Матрица:");
            Console.WriteLine("{0} {1} {2}", arr[0, 0], arr[0, 1], arr[0, 2]);                   Console.WriteLine("{0} {1} {2}", arr[1, 0], arr[1, 1], arr[1, 2]);            Console.WriteLine("{0} {1} {2}", arr[2, 0], arr[2, 1], arr[2, 2]);            Console.WriteLine("Сумма = {0}", sum);            Console.WriteLine("Произведение = {0}", proizvedenie);            Console.ReadLine();     
   }
}
0,0(0 оценок)
Ответ:
Rashidleo
29.05.2023 00:14
// PascalABC.Net 3.0, версия 1066
const
  mm=50;
  nn=50;
var
  n,m,i,j,k1,k2,p:integer;
  s1,s2,s3:longint;
  a:array[1..mm,1..nn] of integer;
begin
  Write('Число строк и столбцов массива: '); Read(m,n);
  Write('Значение p: '); Read(p);
  Writeln('*** Сгенерированный массив ***');
  Randomize;
  s1:=0; s2:=0; s3:=0; k1:=0; k2:=0;
  for i:=1 to m do begin
    for j:=1 to n do begin
      a[i,j]:=Random(101)-50;
      Write(a[i,j]:4);
      if a[i,j]>30 then s1:=s1+a[i,j];
      if Odd(a[i,j]) then Inc(k1)
      else begin s2:=s2+a[i,j]; Inc(k2) end;
      if i+j=p then s3:=s3+a[i,j]
      end;
    Writeln
  end;
  Writeln('Сумма элементов массива, больших 30: ',s1);
  Writeln('Количество нечетных элементов массива: ',k1);
  Writeln('Среднее арифметическое четных элементов массива: ',s2/k2);
  Writeln('Сумма элементов массива c суммой индексов ',p,': ',s3)
end.

Тестовое решение:
Число строк и столбцов массива: 8 10
Значение p: 13
*** Сгенерированный массив ***
 -19 -39 -46  12  41  44 -44  21  11  25
  13 -22   2  36  21 -42  34  15   5  25
  -6  -3 -33 -29  47 -44  33   5  27  23
  14  46  39 -35 -39  -1 -50  49   1  13
  -4 -14  28  40 -34  48   0  -9 -36  12
  -4 -20  35  45 -21  35  44  33  15  34
 -40   2  44  38 -40  18 -11 -14  24 -28
 -42  36 -37  42 -21 -43  19 -22 -45  49
Сумма элементов массива, больших 30: 892
Количество нечетных элементов массива: 40
Среднее арифметическое четных элементов массива: 1.15
Сумма элементов массива c суммой индексов 13: 56
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота