кирилл2127
12.12.2021 01:34

Составьте программу (пикча прикреплена)
И ещё задания самостоятельной работы с 1 по 4
Это два во в одном ьуь :)
(!Засчитаю если что-то одно сделаете тоже из этого!)

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Shoxrux9818
23.03.2022 14:04

например, ввод дополнительной переменной output, которая равна true, если вывод числа (чисел) не был осуществлён и необходимо вывести "123", иначе (если вывод уже был) - false

Объяснение:

int main()

{

setlocale(LC_ALL, "Rus");

double a, b, c, l, k;

bool output = true;

cout << "Введите l: ";

cin >> l;

cout << "Введите k: ";

cin >> k;

a = (l - 2 * k) / l;

b = (l + k) / 5;

c = l * k - 3.5;

if (a >= -5 && a <= 8)

{

cout << "a = " << a << endl;

output = false;

}

if (b >= -5 && b <= 8)

{

cout << "b = " << b << endl;

output = false;

}

if (c >= -5 && c <= 8)

{

cout << "c = " << c << endl;

output = false;

}

if (output)

{

cout << "123" << endl;

}

}

0,0(0 оценок)
Ответ:
Волна1610
23.09.2021 23:25
Программистами обобщенно называют категорию людей, занимающихся разработкой алгоритмов и программ на основе математических моделей. Условно программистов можно разделить на три категории:

Прикладные программисты. Такие специалисты занимаются разработкой конкретных программ, необходимых для работы организации. Например, сюда можно отнести программистов 1С.

Системные программисты программируют операционные системы, интерфейсы к распределенным базам данных, работают с сетями.

Web-программисты имеют дело с сетями, но, как правило, с глобальными, такими, как Internet. Они пишут web-интерфейсы к базам данных, создают динамические web-страницы и т.п.

Специфика профессии:

Плюсы профессии:

Постоянное профессиональное самосовершенствование,

Высокий спрос на рынке,

Высокая заработная плата,

Работать можно не имея диплома,

Преимущественно творческая профессия.

Минусы профессии:

То, что понятно программисту, не всегда понятно пользователю приходится многое объяснять,

Случается работать в авральном режиме,

Работа за компьютером плохо сказывается на здоровье,

И здесь находится место рутине,

Профессия накладывает отпечаток на характер.

Место работы:

Научно-исследовательские центры,

IT-компании,

Организации, которые в свой структуре подразумевают отделы программистов (или штатную единицу).

Личные качества:

Прежде всего, программист должен обладать терпением и выдержкой. Это совершенно незаменимые качества в его работе.

Программирование, бурно развивающаяся область, поэтому нужно уметь быстро адаптироваться и постоянно изучать что-то новое. Иначе через несколько лет ваша ценность как специалиста может заметно снизиться.

Умение объективно оценивать возможности технологий и их использование в каждом конкретном случае. Чтобы не получалось так, что дрова пилятся с применением новейших лазерных разработок.

Карьера и зарплата:

Руководитель группы программистов, IT-директор, менеджер проекта, можно перемещаться в рамках специальности, совершенствуясь профессионально.

Программист: гений поневолеВ его голове цифры, алгоритмы и оригинальные идеи складываются в полезные, простые и доступные программы облегчить жизнь миллионам пользователей персональных компьютеров.

Программист – одна из самых востребованных и высокооплачиваемых профессий в России. Даже не самый продвинутый специалист может найти работу в соответствии со своим уровнем знаний, а затем постепенно учиться и набираться опыта.

Хорошим стартом карьеры может стать присоединение к группе программистов при разработке какого-либо проекта. Крупные проекты часто привлекают внимание западных компаний, которые «перекупают» российских программистов. К примеру, когда-то группа наших молодых ученых разрабатывала процессор «Эльбрус» для Минобороны, а в итоге их всех перекупила корпорация Intel, и теперь наши ученые и программисты работают за рубежом, а сам проект «Эльбрус» потихоньку закрылся. Проблема «утечки мозгов» в этой профессии – одна из самых острых. Впрочем, и в России сегодня у программистов работы предостаточно – они нужны как отечественным компаниям-разработчикам программного обеспечения, так и любой фирме, где существует компьютерная сеть и необходимо адаптировать и настраивать ПО для нужд организации.

К лидерам рынка IT в России можно отнести «Лабораторию Касперского», R-Style, ЛАНИТ, EPAM Systems и др.

Я бы BIOS изобрел…

Спрос на рынке труда на программистов высокий, но и конкуренция соответствующая. Найти интересную и высокооплачиваемую работу вам удастся только в том случае, если вы знаете свое дело «на отлично». Одной из самых сложных в программировании считается разработка системного программного обеспечения – сервисов, которые управляют компонентами вычислительной системы (процессором, коммуникационными и периферийными устройствами, а также тех, которые предназначены для обеспечения функционирования и работо всей системы (загрузчики, операционные системы, драйверы устройств и т. д.). Такие специалисты в России сегодня не слишком востребованы, поскольку практически все продукты подобного рода производятся за рубежом. Поэтому есть шанс найти высокооплачиваемую работу в западных компаниях.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота