kiki0004
27.04.2022 09:59

Составить программу вычисления корней квадратного уравнения по данным значениям его коэффициентов

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
lenka040670
21.07.2020 23:51
Var
a,b,c,d:real;
    begin
        writeln('a,b,c ?');
        readln(a,b,c);
        d:=sqr(b)-4*a*c;
            if d<0 then  writeln('d<0');   
                if d>0 then       
                     writeln('x1= ',((-b)+sqrt(d))/(2*a),'  x2= ',((-b)-sqrt(d))/(2*a)) ;         
                         if d=0 then             
                            writeln('x1= ',(-b)/(2*a)); 
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота