Cfynks
07.11.2022 01:18

1.Напишите программу, которая в последовательности натуральных чисел определяет сумму всех чисел, кратных 8 и оканчивающихся на 6. Программа получает на вход натуральные числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 — признак окончания ввода, не входит в последовательность). Количество чисел не превышает 1000. Введённые числа не превышают 30000. Программа должна вывести одно число: сумму всех натуральных чисел, кратных 8 и оканчивающихся на 6.
2. Напишите программу, которая в последовательности натуральных чисел определяет количество всех чётных чисел, кратных 9. Программа получает на вход натуральные числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 — признак окончания ввода, не входит в последовательность). Количество чисел не превышает 1000. Введённые числа не превышают 30 000. Программа должна вывести одно число: количество всех чётных чисел, кратных 9.
3. Напишите программу, которая в последовательности натуральных чисел определяет количество всех чётных чисел, кратных 5. Программа получает на вход натуральные числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 — признак окончания ввода, не входит в последовательность). Количество чисел не превышает 1000. Введённые числа не превышают 30 000. Программа должна вывести одно число: количество всех чётных чисел, кратных ТОЛЬКО В ПИТОНЕ

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:

/** libraries */

#include <iostream>

#include <cmath>

#include <vector>

#include <map>

#include <set>

#include <queue>

#include <stack>

#include <algorithm>

/** libraries */

using namespace std;

/** defines */

#define ll long long

#define ld long double

#define yes cout << "YES" << "\n"

#define no cout << "NO" << "\n"

/** defines */

signed main() {

   ios_base::sync_with_stdio(false);

   cin.tie(nullptr);

   cout.tie(nullptr);

   ld a;

   cin >> a;

   if(a > 0)

       a += 20;

   cout << a;

}

0,0(0 оценок)
Ответ:
Yakov10
24.01.2023 03:24

1)

const n = 4; m = 4;

var A:array[1..n, 1..m] of integer;

   i, j, iMax, jMax:integer;

begin

 write('Заполнение - Матрица:');

 for i:=1 to n do begin

   for j:=1 to m do begin

     read(a[i, j])

   end;

 end;

 write('Матрица:');

 for i:=1 to n do begin

   writeln;

   for j:=1 to m do begin

     write(a[i, j]:3, ' ');

   end;

 end;

 iMax:=1;

 jMax:=1;

 for i:=1 to n do

   for j:=2 to n do begin

     if a[i, j] > a[iMax, jMax] then begin

       iMax:=i;

       jMax:=j;

     end;

   end;

 writeln;

 writeln('Максимальный элемент: A[', iMax, ', ', jMax, ']=', a[iMax, jMax]);

end.

Вторую не успел сделать, надо уехать.

Объяснение:

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота