STARBOY47
25.04.2020 17:52

На PYTHON. Любые буквы. Напишите программу, выводящую из заданной строки:

а) все цифры;

б) сумму всех цифр;

в) сумму цифр либо сообщение, что в строке цифр нет.​

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Уляна2000002
19.09.2022 20:31

#include <iostream>

using namespace std;

int main()

{

   int mas[20] = {};

   int even = 0;

   int odd = 0;

   for (int i = 0; i < 20; i++)

   {

       cin >> mas[i];

   }

   for (int i = 0; i < 20; i++)

   {

       if (mas[i] % 2 == 0)

       {

           even++;

       }

       else

       {

           odd++;

       }

   }

   if (even > odd)

   {

       cout << "Чётных больше.";

   }

   else if (odd > even)

   {

       cout << "Нечётных больше.";

   }

   else

   {

       cout << "Равное количество.";

   }

}

Объяснение:

#include <iostream> // Библиотека ввода - вывода

using namespace std; // Пространство имён

int main()

{

   int mas[20] = {}; // Создание целочисленного массива размерностью 20, заполненного нулями

   int even = 0; // Создание целочисленной переменной, хранящей количество четных элементов

   int odd = 0; // Создание целочисленной переменной, хранящей количество нечетных элементов

   for (int i = 0; i < 20; i++) // Идём по массиву

   {

       cin >> mas[i]; // Вводим элементы массива с клавиатуры

   }

   for (int i = 0; i < 20; i++) // Идём по массиву

   {

       if (mas[i] % 2 == 0) // Если остаток от деления значения массива mas с индексом i на 2 = 0

       {

           even++; // +1 к четному

       }

       else // Иначе

       {

           odd++; // +1 к нечетному

       }

   }

   if (even > odd) // Если значение переменной even > значения переменной odd

   {

       cout << "Чётных больше."; // Выводим ответ

   }

   else if (odd > even) // Если значение переменной odd > значения переменной even

   {

       cout << "Нечётных больше."; // Выводим ответ

   }

   else // Иначе

   {

       cout << "Равное количество."; // Выводим ответ

   }

}

0,0(0 оценок)
Ответ:
saponovadasha
28.12.2021 10:14

# Подключаем нужный модуль import time # Спрашиваем текст напоминания, который нужно потом показать пользователю print("О чём вам напомнить?") # Ждём ответа пользователя и результат помещаем в строковую переменную text text = str(input()) # Спрашиваем про время print("Через сколько минут?") # Тут будем хранить время, через которое нужно показать напоминание local_time = float(input()) # Переводим минуты в секунды local_time = local_time * 60 # Ждём нужное количество секунд, программа в это время ничего не делает time.sleep(local_time) # Показываем текст напоминания print(text)

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота